


はじめに
本書は、2013年 1月 12日に開催された CSS Nite LP26 「CSS Preprocessor 
Shootout」でのセッション「新世代エディタで作る、プリプロセッサー環境構築
術」での補助資料です。

本書を読むだけでも、役に立つ資料になるように努めましたが言葉が足りない部分
などがあるかも知れません。ご了承ください。
H2O SPACE たにぐち まこと
http://tomosta.jp

CSS Niteについて

2005年10月、アップルストア銀座にてマンスリーイベントとしてスタート。当初は
文字通り「CSS」にフォーカスしていたが、現在は“Web制作者にとって有益であ
ろうトピック”を広く扱っている。

名古屋、大阪、青森、福岡、沖縄、秋田、札幌、福井、仙台、福島、広島、新潟、
京都、石川、高松、山形、富山、静岡、宮崎、熊本、北九州、岡山、徳島、松山、
山梨、長野にて“地方版”を展開。地方版は現地の有志が運営し、地方のコミュニ
ティ活性化の一助となっている。

これまでに、300回を越える関連イベントを通して、のべ40,000名を超える方にご
参加いただいている（2012年11月現在）。
http://cssnite.jp



Sublime Text 2

Sublime Text 2とは
Sublime Text 2（以下、ST2）は、Windows/OS X/Linux向けに開発されているエディタソフト
です。

シンプルながら、非常に高い柔軟性と多くの「パッケージ」と呼ばれる拡張機能が魅力で、2011
年にバージョン2が登場してから、爆発的にユーザーを伸ばしています。

ST2のインストール
ST2は、難しい手続きを必要とすることなく、通常のダウンロードソフトと同様にセットアップす
ることができます。

また、Windows版にはUSBメモリなどにセットアップして、手軽に持ち歩ける「ポータブル版」
も配布されています。いずれも、ダウンロードサイトから入手することができます。

Sublime Text 2
http://www.sublimetext.com/2

セットアップをして、起動すればすぐに使い始めることができますが、そのまま使うだけでは
Sublime Text 2の魅力を感じることはできません。多くの「パッケージ」を入れて、カスタマイ
ズしていくことが必要です。

http://www.sublimetext.com/2
http://www.sublimetext.com/2


なお、本書に出てくる画面ショットは、筆者がカスタマイズを施した状態のものを掲載してお
り、セットアップ直後の見た目とは異なっています。設定の変更・テーマの変更については後述し
ます。

Sublime Package Controlをインストールする
パッケージは、それぞれのダウンロードサイトからダウンロードして手動でインストールすること
もできますが、現在では「Sublime Package Control」という機能を利用するのが一般的です。

Sublime Package Control
http://wbond.net/sublime_packages/package_control

このサイトにアクセスし、画面右の「Install」ボタンをクリックすると次のような画面が表示され
ます。

この、グレーのボックス内に記述されているコードをコピーし、ST2のメニューから
「View→Show Console」を選び、表示されたエリアにこのコードを貼り付けます。

http://wbond.net/sublime_packages/package_control
http://wbond.net/sublime_packages/package_control


Enterを押してしばらくすると「Please restart Sublime Text to finish installation」と表示され
るので、ST2を再起動します。これで、Package Controlが利用できるようになりました。

Package Controlを利用する
再起動した ST2のメニューから「Tools→Command Palette」を選びます（または、ショート
カットの⌘（Ctrl）+Shift+p）。

ここでは、ST2上で実行できるさまざまなコマンドを選ぶことができます。一部を打ち込めば、部
分検索で絞り込むことができるので、ここでは「install」を入力しましょう。「Package 
Control: Install Package」と表示されれば、正常に動作しています。



Enterを押すと、さらにリストが表示されます。これが、ST2にインストールできるパッケージの
一覧です。リストから選んでインストールすることができます。先のコマンドと同様に、名前の一
部から絞り込むこともできます。

例えばここでは、「emmet」と入力してみましょう。



「Emmet」というパッケージが見つかるので、Enterを押してインストールします。Emmetは短
い記述で、HTMLを展開することができる手法で「Zen Coding」の次世代バージョンです。



インストールが完了したら、エディタに「html:5」と入力して「Control+E」と入力しましょう。
次のように、HTML5のタグが展開されます。

こうして、好きなパッケージを追加することで、自分好みのエディタに仕上げることができます。



パッケージを管理する
もし、パッケージを間違えてインストールした場合や、正常に動作しない場合などはコマンドパ
レット（⌘+Shift+P）で、「remove」などと打ち込んで「Remove Package」を選べば、今イン
ストールされているパッケージが一覧されるので、ここから削除することができます。

この他、次のようなコマンドを利用することができます。

• Install Package
パッケージのインストール

• Remove Package
パッケージの削除

• Enable Package
パッケージの有効化

• Disable Package
パッケージの無効化

• Upgrade Package
パッケージのアップグレード



CSSプリプロセッサに便利なパッケージを入れる
それでは、この手順でCSSプリプロセッサや、その他のWeb制作に便利なパッケージをインストー
ルしていきましょう。次のようなパッケージ類を入れておくと良いでしょう。

• HTML5

• CSS Snippets

• LESS

• SASS

• SCSS

• SCSS Snippets

• JavaScript Snippets

• jQuery

• Emmet

• Browser Refresh

• CSScomb

この他にも、無数のパッケージが配布されています。こもりまさあきさんが、公開している Web
制作者向けのパッケージリストなども参考にすると良いでしょう。

ST2: Sublime Text 2 Packages for Web Developers.
https://gist.github.com/4048934

https://gist.github.com/4048934
https://gist.github.com/4048934


設定を変更する
STの設定を行う場合、テキストファイルを書き換えることで行います。Windows版の場合はメ
ニューバーの「Preferences」から（OS X版の場合は一番左のアプリケーション名メニュー内に
「Preferences」があります）、「Settings - Default」を選びます。すると、ST2上に設定ファイ
ルが展開されます。

これを書き換えても構いませんが、ST2をバージョンアップしたときなどに上書きされてしまうた
め、別途「Preferences→Settings - User」とメニューを選んで開く空のファイルの方に書き込み
ます。このファイルは、ユーザー専用の設定ファイルで ST2本体とは別の場所に保存されます。

ここに、上書きしたい設定内容をコピーして内容を書き換えます。例えば、標準のフォントは
「font_face」という項目名になっていて、なにも指定されていませんが、ここに自分好みのフォ
ントを指定する場合はこれをコピーし、次のように書き込みます。

{
 "font_face": "Source Code Pro",
}



保存すると、すぐに反映されますが、設定によっては再起動する必要がある場合もあります。ここ
では、Adobeが無償配布しているプログラミング用フォント「Source Code Pro」を指定しまし
た。

Source Code Pro
https://github.com/adobe/source-code-pro

この他、筆者の設定ファイルは次のようになっています。

{
 "close_windows_when_empty": true,
 "color_scheme": "Packages/User/Solarized (light).tmTheme",
 "draw_white_space": "all",
 "fallback_encoding": "Shift-JIS",
 "font_face": "Source Code Pro",
 "font_size": 14.0,
 "highlight_line": true,
 "highlight_modified_tabs": true,
 "ignored_packages":
 [
  "Vintage"
 ],
 "indent_guide_options":
 [
  "draw_active"
 ],
 "open_files_in_new_window": false,
 "shift_tab_unindent": true,
 "theme": "Soda Light.sublime-theme",
 "trim_trailing_white_space_on_save": true,
 "word_wrap": true
}

以下に最新の設定ファイルを公開しています。
https://gist.github.com/4408074

✴ テーマを変更する
ST2は、「テーマ」という概念で見た目を管理しており、誰でも自由に見た目をカスタマイズする
ことができます。多くのクリエイタがカスタマイズ済のテーマを配布しているため、これをダウン
ロードして利用するだけでも気分を変えることができます。

筆者は、「Soda」というテーマを利用しています。テーマは、パッケージと同じく Package 
Controllerでインストールすることができます。

https://github.com/adobe/source-code-pro
https://github.com/adobe/source-code-pro
https://gist.github.com/4408074
https://gist.github.com/4408074


Package Controllerを起動し、「Package Controll:Install Package」を起動したら「Soda」と打
ち込んでインストールします。

そして、前節に従って設定ファイルに次のように書き込みます（先のサンプルにはすでに反映され
ています）。

 "theme": "Soda Light.sublime-theme",

こうして、ST2を再起動すると反映されます。さらに筆者は、カラースキーマとして
「 SOLARIZED」を組み合わせて利用しています。

SOLARIZED
http://ethanschoonover.com/solarized

これは、手作業でインストールする必要があります。

上記サイトの真ん中あたりに「Click Here To Download Latest Version」というリンクがあるの
で、ZIPファイルをダウンロードして解凍します。

http://ethanschoonover.com/solarized
http://ethanschoonover.com/solarized


ST2を起動し、「Preferences→Browse Packages...」メニューを選びます。パッケージを格納す
るフォルダが開きます。そしたら「User」フォルダを開きましょう。

ここに、スキーマファイルをコピーします。ここでは、解凍した配布ファイル内にある
「textmate-colors-solarized」フォルダ内の「Solarized(light).tmTheme」ファイルをコピーしま
す。



そして、「Preferences→Settings - User」メニューで設定ファイルに、次の記述を追加します。

 "color_scheme": "Packages/User/Solarized (light).tmTheme",

これで、OS Xらしい見た目に変わります。好みに合わせて、カスタマイズをしてみると良いで
しょう。

プロジェクトを作成する
ここまで準備ができたら、いよいよ実際に使い始めることができます。通常のエディタと同様に、
ファイルを開いて編集し、上書き保存をすれば使うことができますが、「プロジェクト」という
機能を使えば、より管理しやすく利用できます。

例えばここでは、CodeKitを使って新しい Compass Projectを作成します。なお本書では、
CodeKit、Compassについての詳細は割愛します。



CodeKitを起動して、「File→Create New Compass Project...」を選びます。

「Create Compass Project」ボタンをクリックすると、保存先のフォルダを問われるので、新し
いフォルダを作るなどしてCompass Projectを作成します。

できあがったフォルダは、そのまま ST2にドラッグドロップしましょう。すると、ST2の画面左
側にそのフォルダの階層リストが表示されます。



フォルダ名を右クリック（または Control+クリック）すると、新しいフォルダ・ファイルを作成
したり、名前の変更や削除なども可能です。

さらにこの状態で、メニューの「Project→Save Project As...」を選択しましょう。名前などを入
力し、「プロジェクト」として今の状態を保存することができます。次回からは、
「Project→Open Project」メニューまたは、「Project→Recent Project」から開くことができま
す。



Coda 2

Coda 2とは
Coda 2は、米Panic社が開発する OS X専用の Webサイト制作ソフトです。コードエディタ機能は
もちろん、サイト管理機能やFTPクライアント・MySQL、SSHクライアントなど、非常に多くの
機能を持ち合わせている軽量でパワフルなアプリです。

なお、本書は筆者が執筆した「Codaでつくる Webサイト制作実践（H2O SPACE刊）」からの抜
粋で構成されています。Coda 2をより深く知りたい場合には、こちらも合わせてご覧下さい。

Codaでつくる Webサイト制作実践
http://p.booklog.jp/book/51419

セットアップから使い始めるまで
それでは、早速Codaを使い始めてみましょう。Codaは、OS X専用のソフトです。読者の方の中
には、Windowsでなければ検討できないと考える方もいるかもしれませんが、近年、Web制作の
現場では急激にMacが浸透して来ています。筆者など、もはやMacでなければ仕事にならない状況
です。
一昔前は、かっこよさのために、多少無理してMacを使っているということも否めませんでした
が、現在ではMacの方が制作・開発マシンとして優れていると言い切ることができます。
Windowsが使い慣れているから、会社がWindowsしか利用できない環境だからなどという理由で
Macを利用しないのは、非常にもったいなといえます。ぜひ、この機会に導入を検討しましょ
う。

✴ AppStore版と直販版
Codaには、OS X（Lion以降）に搭載されている AppStoreを通じて販売されるものと、直販のも
のがあります。それぞれの違いを紹介しましょう。
• iCloud連携機能が搭載[AppStore版のみ]
AppStore版の Codaには、直販版にはない機能として「iCloudによる同期機能」が
搭載されています。これにより「サイト定義」と「クリップ」機能を同期することが
できます。（後述）

http://p.booklog.jp/book/51419
http://p.booklog.jp/book/51419


• ワンタッチバージョンアップ[AppStore版のみ]
AppStoreで購入したアプリケーションソフトは、AppStoreを通じてバージョン
アップ版が配信され、ワンタッチでバージョンアップすることができます。

• 試用版[直販版のみ]
AppStoreでの購入は、試用という制度がないため、購入するとすぐに決済されてし
まいます。直販版の場合は、7日間の試用期間があります。なお、試用期間中は直販
版を利用した後、いったんアンインストールをしてAppStore版を購入することもで
きます（設定は引き継がれません）。

• バージョンアップが早い[直販版]
バージョンアップは、直販版もAppStore版も同時期に行われますが、AppStore版
の場合はアップルによる審査を経ての公開となるため、直販版の方が素早く公開され
ます。

どちらも一長一短がありますが、筆者はiCloudの同期機能などの魅力があるため、AppStore版を
オススメします。

AppStoreを利用する
図のアイコンをクリックして起動し、検索窓に「Coda」と記入して検索しましょう。その場で決
済して購入することができます。（Apple ID及び、クレジットカード登録が必要です。）

クレジットカードをお持ちでない方は、電気店やコンビニエンスストアで購入できる、iTunes 
Cardのコードで購入することもできます。詳しくは、AppStoreのヘルプなどをご覧下さい。



直販版を購入する
以下のWebサイトにアクセスして、セットアップファイルを入手しましょう。

起動する
Codaを起動すると、図のようなサイト管理画面が表示されます。

しかし、この画面はCodaにとって、必須の画面ではありませんので、無視して新しいファイルを
作成しましょう（「⌘+N」）。エディタモードに切り替わります。
これだけで、Codaを利用する準備が整いました。後は、通常のテキストエディタと同様に使い始
めて良いでしょう。少しHTMLやPHPなどを書き始めただけで、タグの補完をしてくれたり、属性



を色分けしてくれたりなど、エディタとしての便利さを実感できるはずです。慣れてきたら、その
他の各機能も徐々に親しんでいきましょう。

プラグイン
Codaは、そのまま利用しても十分便利なソフトウェアですが、他のエディタソフトに比べると、
ちょっと機能が物足りない場合や、使いにくい部分があるかもしれません。
しかし、そんな時は「プラグイン」を利用することで解消することができます。Codaはプラグイ
ンの仕様を一般に公開しており、誰でも開発することができます。また、Codaのオフィシャルサ
イトでもプラグインをリストで紹介されていて、ここを見るだけでも多くのプラグインを利用する
ことができます。
パニック - Coda 2 - プラグイン
http://panic.com/jp/coda/plugins.php
便利そうなプラグインがあったら、試してみましょう。
✴ プラグインをインストールする
プラグインは、ダウンロードすると図のような「.codaplugin」という拡張子のファイルが現れま
す。

このファイルを、ダブルクリックするだけでインストールすることができます。Codaが起動し
（すでに起動している場合はウィンドウが切り替わり）、ほとんどのプラグインでは「プラグイ
ン」メニュー内に専用のメニューが追加されています。

その他、キーボードショートカットに割り当たっていたり、右クリックメニューが追加されている
場合などもありますが、各プラグインのドキュメントや配布サイトを確認しましょう。

✴ Zen Codingを利用しよう
ここでは、数あるプラグインの中でも必携の一つである、Zen Codingを利用できるようにしま
しょう。Codaでの Zen Codingプラグインには、「TEA for Coda」というプラグインがありま
す。次のサイトからダウンロードしましょう。
Zen.Coding-Coda
http://code.google.com/p/zen-coding/downloads/detail?name=Zen.Coding-Coda.v0.7.1.zip
ダウンロードしたら「.codaplugin」という拡張子のファイルをダブルクリックしてインストール
します。すると、「プラグイン→TEA for Coda」というメニューが追加され、その中に Zen 
Codingの項目があります。
✴ 使ってみよう
Zen Codingとは、HTMLのショートカットコードのようなものを打ち込んで変換することで、自
動的にHTMLに展開してくれるというものです。ここでは、新しいHTMLファイルを作成して、次
のように打ち込んでみましょう。



html:5

そして、「Control+E」を押します。すると、次のようなHTMLコードに展開されます。

<!DOCTYPE HTML>
<html lang="en-US">
<head>
	 <meta charset="UTF-8">
	 <title></title>
</head>
<body>

</body>
</html>

また、新しいCSSを作成して次のように打ち込んでも、展開することができます。

bg+

次のようなプロパティになります。

background:#FFF url() 0 0 no-repeat;

こうして、それぞれのショートコードを覚えていけば、非常に素早くコーディングをしていくこと
が可能になります。

✴ Zen Codingをカスタマイズしよう
このように、非常に便利なZen Codingですが、標準では一部使いにくい部分があります。例え
ば、HTML5の基本タグを展開した場合、「lang」属性が「en-US」となっていて日本語を扱う
Webサイトでは扱いにくくなっています。

その他、いつも使うライブラリをあらかじめ埋め込んでおくなど、カスタマイズをすることがで
きます。次の手順で変更してみましょう。

Finderを表示し、「移動」メニューを開きます。「ライブラリ」メニューがあれば、これをク
リックします。メニューに表示されていない場合は「Option」キーを押すと見えるようになりま
す。



「Application Support→Coda 2→Plug-ins」のようにフォルダを辿ると、プラグインのファイル
が見つかります。このアイコンを右クリック（または Control+クリック）し「パッケージの内容
を表示」メニューをクリックします。

すると、実はこのプラグインはフォルダ構成になっており、さらに中にファイルなどが収まってい
ます。「Support→Library→zencoding」とフォルダを辿り、「zen_setting.py」というファイル
をエディタソフトで開きます。Codaで開いても良いでしょう。

11行目付近から始まる、次の行を日本語向けに書き換えます。

書き換えると、次のようになります。



また、出力されるHTMLファイルは、同じファイル内に記述されているので、ショートコードで検
索をしてみると良いでしょう。例えば「html:5」で生成されるコードは、561行目付近から始まり
ます。

これを書き換えると、生成されるHTMLが変わります。こうしてファイルを保存し、Codaを再起
動しましょう.

【コラム】Emmetを利用する
Zen Codingは 2012年現在、機能を向上し、名前を一新して「Emmet」というプロ
ジェクト名で開発が進められています。

Emmetでは、Zen Codingの機能はそのままに、機能の追加や置き換えなどが行われていま
す。例えば、Zen Codingでは次のようなHTMLを生成する場合、

<div id="main">
    <p></p>
</div>
<div id="sub">

次のようなコードを記述する必要がありました。

(div#main>p)+div#sub

しかし、Emmetの場合は新しく「^」という記号で、一つ上のレベルに戻ることができるよ
うになったため、次のように記述することができます。



div#main>p^+div#sub

Codaもすでに、Emmetに対応したプラグインがリリースされており、これをインストール
することで利用できます。次の手順でインストールしましょう。

• はじめに、「TEA for Coda」とショートカットキーなどが重複しているため、先
に削除しておきます。ユーザーディレクトリの「ライブラリ→Application 
Support→Coda 2→Plug-ins」と移動して、「TEA for Coda.codaplugin」ファイ
ルを削除します。

• 次のサイトから、Coda用のプラグインである「Emmet for Coda」というファイ
ルをダウンロードして、ZIPファイルを解凍します。
https://github.com/emmetio/emmet-objc/downloads

• 拡張子が「.codaplugin」のファイルをダブルクリックしてインストールします

これで「プラグイン」メニューに「Emmet」が追加され、利用できるようになりま
す。上記のコードなどを記述して「Control+E」のショートカットで展開してみてく
ださい。

LESS用プラグインを追加する
Coda 2は、標準で Sassには対応していますが LESSは対応していません。利用する場合には、上
記と同じ方法で次のプラグインをインストールします。

LESS CSS Plugin for Coda
http://incident57.com/coda/index2.php

サイト定義を使おう
FTP接続をしてファイルを管理するなら、「サイト定義」をした方がなにかと便利になります。
FTPの接続先を保存しておくことができ、さらに簡単な操作でファイルをアップロードしたり、ダ
ウンロードして最新版に保つことも可能になります。
サイトは、初回起動時に表示されているほか、ツールバーの左端の「サイト」ボタンをクリックす
ることで移動することができます。

http://incident57.com/coda/index2.php
http://incident57.com/coda/index2.php


ここで、画面右下の「+」ボタンをクリックするか、「Shift+⌘+A」のショートカットで新規サイ
トウィンドウが表示されます。

次の各項目を設定していきましょう。

✴ サイト名
サイト一覧を見たときに、見分けがつくような名前にします。

✴ プロトコトル・サーバーアドレス・ユーザ名・パスワード
それぞれ、FTPの情報を設定していきます。パスワードは保存させずに「その都度尋ねる」に
チェックを入れても良いでしょう。



✴ トップページ
ここには、FTPでアップロードした時のWebサイトのURLを入力します。例えば、

http://h2o-space.com

などと入力すれば、後でプレビューなどに利用することができるようになります。入力しなくて
も構いません。

✴ ローカルURL
MAMP（後述）などを用いて、ローカルサーバーを利用している場合にここにそのアドレスを入
力することで、プレビューなどで利用することができます。

✴ リモートルート
FTPで接続をしたときに最初に表示されるディレクトリを入力します。「ドキュメントルート」や
「ウェブルート」などとも呼ばれます。例えば、レンタルサーバー「Heteml」の場合は「web/」
がリモートルートになります。

✴ ローカルルート
開発しているWebサイトのファイル群を保存しているディレクトリを指定します。ファイルパネル
の初期位置として指定することができます。

以上の設定を行うと、自動的にトップページのキャプチャが撮影されて、アイコンとして利用され
ます。



そのWebサイトに BASIC認証を設定している場合などは認証ウィンドウが出てくるので、IDとパ
スワードを記入してログインしましょう。

画面下のスライダーを利用して、大きさを調整することができます。また、複数作成した場合に順
番がばらばらになってしまったら、空いているエリアを右クリック（Control+クリック）して
「整頓」メニューで整頓し直すこともできます。

また、「グループ」を作ることもできます。まとめたいアイコンをドラッグドロップで他のまとめ
たいアイコンに重ねると、以下の図のようにグループができあがります。

【ワンポイント】FTPに接続できない場合

定義したサイトを開くときに、次のようなエラーメッセージが表示されることがあり
ます。

この場合、次のような点をチェックして行くと良いでしょう。

・各種情報の書き間違い



最も多いのは、サーバーアドレスやID、パスワードの書き間違いです。改めて定義書
類などを確認しながら、正しく設定しましょう。

・プロトコルの違い

FTPには大きく分けて、「FTP」「FTPS」「SFTP」などの種類があります。改めて
確認しましょう。

・パッシブモードのチェックを変更してみる

FTPには接続の方法に「パッシブモード」があります。標準でこのチェックボックス
にはチェックが付いた状態になっていますが、これを外すことで接続できる場合が
あります。試してみると良いでしょう。

【ワンポイント】iCloudでのサイト定義の同期

AppStore版でCodaを購入をすると、iCloudでの同期機能がサポートされます。「環
境設定→一般」から「iCloud」のチェックをつけると、サイト定義（とクリップ
（後述））が iCloudにアップロードされ、別の環境から同じアカウントでログイン
している Codaに同期されます。

デスクトップパソコンとノートパソコンなど、複数の環境で利用している場合に便利
でしょう。

【ワンポイント】複数のサイトを同時に編集する

Codaは、1つのウィンドウでは1つのサイトしか編集することができません。もし、
複数のサイトを同時に編集する場合は「ファイル→新規ウィンドウ」メニュー
（ショートカットはShift+Control+N）で新しいウィンドウを開き、別のサイトを開
くと良いでしょう。



また、サイトのアイコンを右クリックすると「新規ウィンドウで開く」というメ
ニューがあり、これでも同じように新しいウィンドウで開くことができます。

【ワンポイント】Transmitからの「お気に入り」の取り込み

Codaを開発しているPanic社は、FTPのクライアントソフトである「Transmit」と
いう製品も販売しており、利用している方も多いでしょう。

Codaには、このTransmitの「お気に入り」をサイトの情報として取り込む機能があ
ります。「ファイル→サイト→Transmit お気に入りを読み込む」メニューで、取り
込みたい接続情報を選びます。

また逆に、Transmitにも「お気に入り→読み込み→Coda」メニューからサイト情報
を取り込むメニューが準備されており、こうして両製品を使い分けて1つのサイトを
メンテナンスすることができます。

【コラム】Codaと Transmitの使い分け

Codaを利用していると、Transmitを利用する機会はあまりないかもしれません。特
に、Coda 2からは FTPのエンジンが強化され、前バージョンでは容量の大きなファ
イルの取得に失敗したりしていた現象が少なくなったように感じます。

Transmitにあって Codaにない機能としては、次のようなものがあります。

ファイルの同期

サーバー同士でのファイルのやりとり

サーバー上のフォルダを通常のフォルダに用に扱える「Transmitディスク」



タブを利用した複数のサーバーへの同時接続

このようにネットワークフォルダを高度に扱いたい場合に、Transmitは威力を発揮
します。魅力を感じたら、Codaと一緒に利用すると良いでしょう。

公開機能を使いこなそう
サイト定義を利用する最大のメリットは「同期機能」が利用できるようになることです。
サイト定義で「リモートルート」と「ローカルルート」を正しく設定すると、Codaは両フォルダ
を監視し、ファイルの数や更新日時に差異がないかを確認するようになります。

そして、ローカルルート上のファイルを変更するとサイドバーの「公開」ボタンに、図のように数
字バッジが表示されるようになります。

これをクリックすると、図のように変更されたファイルが一覧され、下部のボタンから一括で
アップロードをすることができます。

こうして、編集から公開までの流れをスムーズに制御することができます。



なお、もし他のエディタソフトなどでファイルを変更した場合で、公開対象のファイルにならな
かった場合、公開したいファイルを右クリック（Control+クリック）して「公開マークをつけ
る」をクリックすることで、リストに加えることができます。

【ワンポイント】監視はローカルルートのみ

Codaが監視するのはローカルルートの変更のみです。そのため、他の人がサーバー
上のファイルを変更している場合などに、ローカルルートの方が「古い」ということ
は通知されませんので注意しましょう。

そのまま「公開」をすると、リモートルート上のファイルが上書きされてしまいま
す。複数人で管理しているWebサイトの場合は、作業を始める前に必ず最新ファイル
をダウンロードしてから進めるようにしましょう。

【ワンポイント】「公開」と「アップロード」の違い

一括公開の他に、1つのファイルを選択しての公開も行うことができます。公開した
いファイルを右クリックすると「【サイト名】へ公開」メニューが表示されます。こ
れをクリックすると、リモートルートにアップロードされます。

しかしここで、同じメニューに「【ファイル名】をアップロード」という機能もあ
ります。この二つの機能の違いはなんでしょうか。それは、「フォルダ構成を意識す
るか」にあります。

「アップロード」は、リモート機能で現在表示されているフォルダにアップロード
されます。つまり、そのファイルが「/index.html」というファイルなのか「/dir1/
dir2/index.html」とフォルダの中のファイルなのかは無視され、リモート側で今表
示されているフォルダにアップロードされます。



逆に、「公開」ではフォルダ構成が保持されます。つまり「dir1/dir2/index.html」
というファイル公開した場合はリモート上に「dir1/dir2」というフォルダが作成さ
れ、ファイルがアップロードされます。

基本的にサイト定義をした後で「アップロード」の機能を利用することはあまりあ
りません。

プレビュー機能
Codaには、ブラウザ機能が内蔵されていて、作成しているファイルをその場で簡単にプレビュー
することができます。
エディタでファイルを編集していると、常に上部のパスバーに「Preview」ボタンが表示されてい
て、これをクリックすることでブラウザに切り替えることができます。キーボードショートカット
の「⌘+4」でも切り替えることができます。

プレビューが終わったら、隣のファイル名をクリックするか、「⌘+3」でエディタに戻ります。
ここで表示されるWebブラウザは、Safariとほぼ同等の機能を持っており、WebKit系のWebブラ
ウザの確認ならここで済ますことができます。JavaScriptも正常に動作します。

✴ Webインスペクタ・ソースを表示する
画面下部の各ボタンをクリックすると、要素の解析や、JavaScriptのデバッグなどに利用する
「Webインスペクタ」や、生成されたHTMLを閲覧する「ソース」など表示することもできます。
PHPなどの開発で、生成されたHTMLを確認したいときなどに利用するとよいでしょう。



✴ ユーザーエージェントを変更する
Webブラウザごとの挙動を確認する場合は、画面右下の歯車ボタンをクリックし、「ユーザエー
ジェント」メニューから各ブラウザを選択すれば、変更することができます。iPhoneなどのエー
ジェント情報もありますが、バージョンの新しいブラウザはリストになく、現状このリストを変
更する方法はないようなので、Codaのバージョンアップを待つ必要があるようです。

✴ 外部ブラウザでプレビューする
FirefoxなどのWebKit系以外のWebブラウザでプレビューしたい場合や、Google Chromeなどで
詳細に分析をしたい場合は、外部ブラウザと連携します。画面左下の歯車ボタンの「このアプリ
ケーションで開く」メニューから、ブラウザを選んで起動しましょう。
一番先頭に表示されているWebブラウザは、キーボードの「⌘+Option+B」でも起動することが
できます。このブラウザは、OS Xの設定で「デフォルトWebブラウザ」に設定されているWebブ
ラウザが採用されます。
変更したい場合は、Safariの環境設定から変更しましょう。

✴ 任意のURLをプレビューする
Codaのプレビューウィンドウは、Webブラウザとして完全に機能するため、編集中のファイル以
外のURLもプレビューすることができます。
図のアドレスバーをクリックし、URLを変更してEnterキーを押せば、そのURLに移動することが
できます。PHPのフレームワークなどを利用している場合や、WordPressなどのテーマファイルを
編集している場合などで、編集しているファイルと実際のパスが異なる場合に、利用するとよいで
しょう。



ウィンドウの分割
Codaは、シングルウィンドウのアプリケーションですがウィンドウを分割することで、複数の
ファイルを閲覧することなどができます。画面右上の分割ボタンをクリックと、選択肢が表示され
るためここから「書類」を選ぶと、同じファイルを閲覧することができます。「⌘+Control+L」
を押しても分割できます.

分割したウィンドウは、それぞれ独立してスクロールをしたり、開くファイルを変えたり、プレ
ビューやブック（後述)を表示することなどもできます。
なお、分割したウィンドウにファイルを開くとき、ダブルクリックなどで開くと新しいウィンドウ
が開いてしまったりするため、一番確実なのは図の部分に開きたいファイルをドラッグドロップ
すると良いでしょう。



複数分割することもできるので、画面が広い場合は同時にいくつものファイルを編集することがで
きます。
不要なウィンドウは、図のボタンをクリックするか「⌘+W」で閉じることができます。

✴ 縦分割
また、分割ウィンドウがない状態で「Option」キーを押しながら、分割ボタンをクリックすると
縦方向に分割することもできます。「環境設定」から、縦分割を標準に設定することもできます。

ただし、縦分割と横分割を混在させることはできません。



プレビューとの組み合わせでライブプレビュー
ウィンドウ分割が力を発揮するのは、プレビューウィンドウと組み合わせたときでしょう。図の
ように、縦分割をしてプレビューウィンドウを表示するのがおすすめです。

同時に編集しているHTMLとCSSも開いておきます。Codaのプレビューウィンドウは、編集して
いるファイルと、プレビューウィンドウに表示されているパスが一致している場合、ファイルを保
存すると自動的に再読み込みされるため、通常のWebブラウザに表示するよりも、スムーズにプ
レビューをすることができます。
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